8.х 1С:Предприятие 8.2 занятие 13 Отчеты

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем NastyaTT, 28 ноя 2011.

  1. TopicStarter Overlay
    NastyaTT
    Offline

    NastyaTT

    Регистрация:
    28 ноя 2011
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте.
    Делаю занятие 13 по книге М.Г. Радченко 1С:Предприятие 8.2, застряла на отчете "Рейтинг услуг", ни в какую не хочет выводить в отчете выручку. Как это можно исправить?
  2. Azamat
    Offline

    Azamat Опытный в 1С

    Регистрация:
    29 июл 2011
    Сообщения:
    271
    Симпатии:
    0
    Баллы:
    26
    можете выложить свою выгрузку, чтобы мы могли глянуть
  3. jguar
    Offline

    jguar

    Регистрация:
    1 фев 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Волнует этот вопрос. Кто сталкивался с этой проблемой, и какие файлы на выгрузку нужны?
  4. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Файлы никакие не нужны. Это все кодом пишется.
  5. jguar
    Offline

    jguar

    Регистрация:
    1 фев 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Спасибо. :) Уже разобрался
  6. jguar
    Offline

    jguar

    Регистрация:
    1 фев 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Код:
    Процедура ОбработкаПроведения(Отказ, Режим)
        //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
        // Данный фрагмент построен конструктором.
        // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
    
        // регистр ОстаткиМатериала Расход
        Движения.ОстаткиМатериала.Записывать = Истина;
        Движения.СтоимостьМатериалов.Записывать = Истина;
        Движения.Продажи.Записывать = Истина;
     
        Для Каждого ТекСтрокаПереченьНоменклатуры Из ПереченьНоменклатуры Цикл
            //добавили
            Если ТекСтрокаПереченьНоменклатуры.Номенклатура
                .ВидыНоменклатуры = Перечисления.ВидыНоменклатуры.Материал Тогда
             
                //регистр ОстаткиМатериаов Расход
                Движение = Движения.ОстаткиМатериала.Добавить();
                Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
                Движение.Период = Дата;
                Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
                Движение.Склад = Склад;
                Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
             
                //регистр СтоимостьМатериалов Расход
                Движение = Движения.СтоимостьМатериалов.Добавить();
                Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
                Движение.Период = Дата;
                Движение.Материал = ТекСтрокаПереченьНоменклатуры.Номенклатура;
                Движение.Стоимость = ТекСтрокаПереченьНоменклатуры.Количество
                                        * ТекСтрокаПереченьНоменклатуры.Стоимость;
                                     
            КонецЕсли;  <- конец условия стоял перед КонецЦикла;
                //РегистрПродажи
                Движение = Движения.Продажи.Добавить();
                Движение.Период = Дата;
                Движение.Номенклатура = ТекСтрокаПереченьНоменклатуры.Номенклатура;
                Движение.Клиент = Клиент;
                Движение.Мастер = Мастер;
                Движение.Количество = ТекСтрокаПереченьНоменклатуры.Количество;
                Движение.Выручка = ТекСтрокаПереченьНоменклатуры.Сумма;
                Движение.Стоимость = ТекСтрокаПереченьНоменклатуры.Стоимость
                                        *ТекСтрокаПереченьНоменклатуры.Количество;
                                     
        КонецЦикла;
    
        //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
    КонецПроцедуры
    Последнее редактирование модератором: 3 фев 2015

Поделиться этой страницей