8.х 1с 8.3 зуп проблемы при выгрузке зарплатного реестра

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Mambo, 17 фев 2016.

  1. TopicStarter Overlay
    Mambo
    Offline

    Mambo

    Регистрация:
    22 май 2014
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    Есть обработка от раруса "Выгрузка зарплатных реестров из программ "1С" для ОАО "Альфа-банк"" Проблема при формирования реестра не видит каталог выгрузки "Отсутствует каталог или доступ к выбранному каталогу выгрузки: "D:\1с"" права были указаны полные и добавлен пользователь с полными правами для данного каталога. Это проблему не решило. При отладке в процедуре ОбработкаПроверкиЗаполнения в модуле объекта выполняется условие при не существовании каталога.
    Код:
    Процедура ОбработкаПроверкиЗаполнения(Отказ, ПроверяемыеРеквизиты)
        Если Найти(ПризнакиКонфигурации, "Ведомость") Тогда
            ПроверяемыеРеквизиты.Добавить("ЗарплатныйПроект");
        ИначеЕсли Найти(ПризнакиКонфигурации, "Банк") Тогда
            ПроверяемыеРеквизиты.Добавить("Организация");
            ПроверяемыеРеквизиты.Добавить("Банк");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров.Организация");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров.НомерДоговора");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров.ДатаДоговора");
        Иначе
            ПроверяемыеРеквизиты.Добавить("Организация");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров.Организация");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров.НомерДоговора");
            ПроверяемыеРеквизиты.Добавить("НомераДоговоров.ДатаДоговора");
        КонецЕсли;
        Если НЕ Найти(ПризнакиКонфигурации, "Ведомость") И ЗначениеЗаполнено(Организация) И НЕ РеквизитыДоговораЗаполнены() Тогда
            Отказ = Истина;
            Сообщить("Для выбранной организации """ + Организация + """ не заданы номер и дата договора с банком");
        КонецЕсли;
        Файл = Новый Файл(СокрЛП(КаталогВыгрузки)); // проверка существования каталога
        Если Не Файл.Существует() Тогда
            Отказ = Истина;
            Сообщить("Отсутствует каталог или доступ к выбранному каталогу выгрузки: """ + КаталогВыгрузки + """");
        КонецЕсли;
    КонецПроцедуры
  2. TopicStarter Overlay
    Mambo
    Offline

    Mambo

    Регистрация:
    22 май 2014
    Сообщения:
    32
    Симпатии:
    0
    Баллы:
    1
    проблема проявляется в клиент серверной версии. на файловой версии все нормально отрабатывает.

Поделиться этой страницей