1С 8.3 УФ Получение адреса для контрагента

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ExtreMe, 17 окт 2014.

  1. TopicStarter Overlay
    ExtreMe
    Offline

    ExtreMe Опытный в 1С

    Регистрация:
    13 сен 2014
    Сообщения:
    76
    Симпатии:
    7
    Баллы:
    29
    мой код выполняет то что мне надо
    а как нормально можно получить адрес для контрагента в 1С 8.3 Бухгалтерия из внешней обработки?
    Код:
    &НаСервере
    Функция  ПолучитьАдрес(СсылкаНаОбъект)
        КонтИнф = СсылкаНаОбъект.ГоловнойКонтрагент.КонтактнаяИнформация;
        Для каждого СчетчикСтр Из КонтИнф Цикл
            Если СчетчикСтр.Вид.Наименование = "Юридический адрес" Тогда
                Результат = СчетчикСтр.Город;
            КонецЕсли;
        КонецЦикла;
        Возврат Результат;
    КонецФункции
    
    &НаКлиенте
    Процедура ДокументОбъектГрузоотправительПриИзменении(Элемент)
        ПунктПогрузки = ПолучитьАдрес(Объект.ДокументОбъект.Грузоотправитель);
    КонецПроцедуры
    
    в 8.2 можно было обойтись общим модулем
    УправлениеКонтактнойИнформацией.ПрочитатьКонтактнуюИнформацию()
    Последнее редактирование: 17 окт 2014
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    ExtreMe вашу задачу не знаю. С БП3 также не работаю. Но что мешает воспользоваться типовыми функциями? Откройте модуль менеджера, например документа реализация товаров услуг, там есть процедуры печати документа (например в ТОРГ-12 уж однозначно выводится юр. адрес контрагента). Что не так у вас, если сделать по подобию?
    --- Объединение сообщений, 17 окт 2014 ---
    Так, все сообщения не касающиеся вопроса поудалял (в том числе отредактировал свое). Дальше давайте по теме.
    Последнее редактирование: 17 окт 2014
    alexburn нравится это.
  3. TopicStarter Overlay
    ExtreMe
    Offline

    ExtreMe Опытный в 1С

    Регистрация:
    13 сен 2014
    Сообщения:
    76
    Симпатии:
    7
    Баллы:
    29
    ладно, гляну ;)
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Тут дело вот в чем. Адрес представляется как "некая" структура, т.е. структурированная запись, что это означает ? Каждое словосочетание адреса является неким элементом определенной структуры и плюс еще тип, что позволяет, например, делать отбор по определенным, допустим, регионам. Вышеприведенный код получает не структуру адреса, а его ПРЕДСТАВЛЕНИЕ, т.е. тупо строку, и вычленить какой-то элемент из этой записи по-нормальному не получится (извращение с Прав() и Лев() это гемор, т.к. нужно точно знать СТРУКТУРУ АДРЕСА, т.е. на какой позиции находится индекс или улица).
    Вышеприведенный код подходит конечно для вывода на печать или еще куда-то, где не требуется обработка этого адреса.
    Последнее редактирование: 18 окт 2014

Поделиться этой страницей