8.х 1С 8.3 - Мобильное приложение. Ошибка - ДиалогВыбораФайла.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ифкпфт009, 23 авг 2016.

  1. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте.
    Создаю мобильное приложение и столкнулся с такой проблемой:
    Создал обработку для выполнения обмена данными с именем ОбменДанными.
    Есть реквизит - УзелОбмена(ПланОбменаСсылка.Мобильные) и 3 команды :
    - Зарегистрировать изменения
    - Выгрузить данные
    - Загрузить данные
    Код:
    &НаКлиенте
    Процедура ВыгрузитьДанные(Команда)
        Режим = РежимДиалогаВыбораФайла.ВыборКаталога;
        Диалог = Новый ДиалогВыбораФайла(Режим);
        Диалог.Заголовок = "Укажите каталог информационной базы: ";
        Если Диалог.Выбрать() Тогда
            ВыгрузитьДанныеНаСервере(Объект.УзелОбмена, Диалог.Каталог);
        КонецЕсли;
       
    КонецПроцедуры
    
    &НаСервереБезКонтекста
    Процедура ЗагрузитьДанныеНаСервере(Узел, Каталог)
        УзелОбъект = Узел.ПолучитьОбъект();
        УзелОбъект.ПрочитатьСообщениеСИзменениями(Каталог);
       
    КонецПроцедуры
    
    Суть в том что ругается на ДиалогВыбораФайла.
    {Обработка.ОбменДанными.Форма.Форма.Форма(41,17)}: Тип не определен (ДиалогВыбораФайла)
    Диалог = Новый <<?>>ДиалогВыбораФайла(Режим); (Проверка: Мобильное приложение-клиент)
    Что может быть не так? в синтаксис помощнике смотрел, также все.
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Написано ж: тип не определен для мобильного приложения.
    Конструктор ДиалогВыбораФайла не доступен для мобильного приложения.
  3. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    и что делать?
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Использовать конструктор, доступный для мобильного приложения.
  5. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    например?
  6. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Например, НачатьПомещениеФайла, либо почитать книжки по разработке мобильного приложения.
  7. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    а я что делаю)) это код из книги хрусталева - разработка мобильного приложения( для 8.3 )
  8. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Режим использования модальности в конфигурации из книги, вероятно, отличается от установленного в вашей конфигурации.
  9. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Вычитал на другом форуме, убрать галку то что это мобильное приложение и все ок.
    Я думал можно сделать 1 конфигурацию и как обычное приложение и мобильное, оказывается нужно создать новую конф. для мобильного приложения.

Поделиться этой страницей