1С 8.1 Розница + Фелик 02К + Безнал: Нулевые чеки, Нулевые чеки

Тема в разделе "Торговое оборудование в 1С", создана пользователем NikolaevAV, 24 ноя 2009.

  1. TopicStarter Overlay
    NikolaevAV
    Offline

    NikolaevAV

    Регистрация:
    12 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Собственно проблема в следующем:
    имеется 1С 8.1 конфигурация Розница ФР Феликс 02К подключается к 1с по средством стандартной атолловской обработки ATOLFiscalPrinters_v2.1.epf
    при продаже налом - все нормально, но вот при продаже по безналу - после печати слип чека выводится нулевой чек и только после него печатается фискальный чек, все быничего но во время закрытия смены при сверке итогов по безналу - происходит то же самое, то есть сначала печаается информация по безналу отом нулевой чек а потом z-отчет вся проблема в том что из за этого нулевого чека номера z-отчетов идут через 1, то есть 1,3,5 а номера 2 и 4 забирают на себя нулевые чеки.

    Смотрел код обработки

    Код:
    // Функция осуществляет построчную печать нефискального чека из переданного массива строк.
    Функция НапечататьСтроки(Объект, МассивСтрок, Ширина) Экспорт
    
    Результат = мНетОшибки;
    НомерЧека = 0;
    НомерСмены = 0;
    
    ОткрытьЧек(Объект, "", Ложь, НомерЧека, НомерСмены, Истина);
    Для Каждого СтрокаТекста Из МассивСтрок Цикл
    Если Не Объект.Драйвер.НапечататьНефискСтроку(Объект.ИДУстройства, СтрокаТекста) Тогда
    Результат = мОшибкаНеизвестно;
    Объект.Драйвер.ПолучитьОшибку(Объект.ОписаниеОшибки);
    Объект.Драйвер.ОтменитьЧек(Объект.ИДУстройства);
    Прервать;
    КонецЕсли;
    КонецЦикла;
    
    ЗакрытьЧек(Объект, 0, 0);
    
    Возврат Результат;
    
    КонецФункции
    
    по всей видимости это происходит из-за: ЗакрытьЧек(Объект, 0, 0);

    как можно с этим побороться.
  2. TopicStarter Overlay
    NikolaevAV
    Offline

    NikolaevAV

    Регистрация:
    12 ноя 2009
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Ни у кого нет ни каких мыслей по этому поводу?
Похожие темы
  1. piligrym
    Ответов:
    1
    Просмотров:
    1.944
  2. Tayana_M
    Ответов:
    13
    Просмотров:
    2.736
  3. Peroman
    Ответов:
    10
    Просмотров:
    2.605
  4. Danial
    Ответов:
    9
    Просмотров:
    2.930
  5. К_Е
    Ответов:
    1
    Просмотров:
    1.241
Загрузка...

Поделиться этой страницей