7.7 1С 7 имя счета в ТиС, Win7 32 bit

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем vidok2010, 20 фев 2012.

  1. TopicStarter Overlay
    vidok2010
    Offline

    vidok2010

    Регистрация:
    24 дек 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте, подскажите, искал не нашел, но должна быть тема популярна. При сохранении счета (для отправки в электронном виде) приходится каждый раз делать определенные действия. Хотелось бы как-нибудь автоматизировать сей процесс.
    Имеются определенные критерии сохранения файла, при нажатии Файл-Сохранить как:
    1. Тип файла - не *.mxl как предлагает 1с по умолчанию а *.xls.
    2. Имя файла - из документа: Название организации которой выставляют счет_номер заявки_дата_сумма документа.руб.
    3. Путь сохранения файла - определенная папка.

    Как правильно подойти к этому вопросу? Через глобальный модуль или же внешней обработкой к документу "Неподтвержденная заявка" Может уже делали такое?
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Под "счетом" вы понимаете печатную форму?

    Тогда самый простой способ - вынести во внешнюю обработку (сделать копию, если уже внешняя), дописать код - после формирования печатной формы сохранить в файл.
  3. TopicStarter Overlay
    vidok2010
    Offline

    vidok2010

    Регистрация:
    24 дек 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Да

    После формирования печатной формы, в конце процедуры печать вставил:

    Код:
    ИсхТабл.Записать(""+Контрагент+"_"+НомерДок+"_"+ДатаДок+"_"+глФРМ(СуммаИтог, Валюта)+"xls",1);
    ПереносДоковВОтдельнуюПапку();
    Чуть выше эта процедура выглядит так:
    Код:
    Процедура ПереносДоковВОтдельнуюПапку()
    ФС.УстТекКаталог(КаталогИБ());
    ИмяФайла = "";
    ИмяФайла = ФС.НайтиПервыйФайл("*.xls");
    Если ИмяФайла <> "" Тогда
    ФС.СоздатьКаталог("Счета");
    ФС.КопироватьФайл(ИмяФайла,ФС.ТекКаталог() + "Счета" + ИмяФайла);
    ФС.УдалитьФайл(ИмяФайла);
    Пока 1=1 Цикл
    ИмяФайла = " ";
    ИмяФайла = ФС.НайтиСледующийФайл();
    Если ИмяФайла <> "" Тогда
    ФС.КопироватьФайл(ИмяФайла,ФС.ТекКаталог() + "Счета" + ИмяФайла);
    ФС.УдалитьФайл(ИмяФайла);
    Иначе
    Прервать;
    КонецЕсли;
    КонецЦикла;
    КонецЕсли;
    КонецПроцедуры
    Затык пока в этом:

    Ошибка при выполнении команды;
    ФС.КопироватьФайл(ИмяФайла,ФС.ТекКаталог() + "Счета" + ИмяФайла);
    {Документ.ЗаявкаПокупателя.Форма.Модуль(841)}: Недостаточное число параметров передано при вызове функции/процедуры объекта
  4. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    А зачем переносить файлы? Пишите его сразу в нужный каталог.
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    1) Не хватает параметра
    Код:
    ФС.КопироватьФайл(ИмяФайла,ФС.ТекКаталог() + "Счета" + ИмяФайла,0);
    
    2) Для удобства на форму я бы добавил кнопку сохранения (по аналогии с кнопками обновить/настройка типовых отчетов)
    Пользователь видит результат и тут же может сохранить (как вариант - сразу отправить если в справочнике контрагента указан эл. адрес)
    Удобно.
  6. TopicStarter Overlay
    vidok2010
    Offline

    vidok2010

    Регистрация:
    24 дек 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Переношу потому что не знаю как сохранить сразу в нужный


    Это было бы идеально! Но пока не знаю как это сделать.
  7. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Код:
    ИсхТабл.Записать(КаталогИБ() + "Счета\" + Контрагент+"_"+НомерДок+"_"+ДатаДок+"_"+глФРМ(СуммаИтог, Валюта)+"xls",1);
  8. TopicStarter Overlay
    vidok2010
    Offline

    vidok2010

    Регистрация:
    24 дек 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Не создает документ вовсе (
    А, сори, папку надо ручками один раз создать)
    А если не в каталоге ИБ, то как? Например d:\1с\Счета\
  9. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    А каталог "Счета" в каталоге с ИБ есть?
  10. TopicStarter Overlay
    vidok2010
    Offline

    vidok2010

    Регистрация:
    24 дек 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    А, сори, папку надо ручками один раз создать)
    А если не в каталоге ИБ, то как? Например d:\1с\Счета\
  11. Requin
    Offline

    Requin Опытный в 1С

    Регистрация:
    10 май 2010
    Сообщения:
    1.911
    Симпатии:
    2
    Баллы:
    29
    Именно так. В методе Записать указывайте полное имя файла.
  12. TopicStarter Overlay
    vidok2010
    Offline

    vidok2010

    Регистрация:
    24 дек 2010
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Спасибо! Как все просто, оказывается)

    А какой самый простой способ отправки можно тут придумать?
  13. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    я бы рекомендовал использовать ВК rommail

Поделиться этой страницей