7.7 1С 7.7 и интернет

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем FUX, 13 мар 2013.

  1. TopicStarter Overlay
    FUX
    Offline

    FUX

    Регистрация:
    10 сен 2011
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Добрый день. Кто подскажет,может видел или скинет ссылку на обработку , которая в 1с 7.7 будет позволять, находясь в 1с(т.е. не открывать отдельно интернет браузер), просматривать сайты интернета или работать в интернете, своего рода встроенный в 1с интернет-браузер. Нашел подобный(прикрепленный файл), но для 1с 8.2, а нужен для 1с 7.7.

    Вложения:

  2. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    вставить ActiveX контрол браузера на форму и пользоваться
  3. TopicStarter Overlay
    FUX
    Offline

    FUX

    Регистрация:
    10 сен 2011
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    можно пожалуйста по подробней? с чего начать? я тут скачал компоненсту 1с++ и пробную форму с модулем , но сайт не отображается , прост чистый фон. ошибок никаких не выдает.
    Код:
    Процедура ПриОткрытии()
    Попытка
    гФорма=СоздатьОбъект("СервисРасшФормы");
    гФорма.ЗагрузитьМодуль(); //ПослеОткрытия
    Исключение
    гФорма=СоздатьОбъект("Форма");
    гФорма.УстановитьФорму(Форма); //ФормаПриСоздании
    КонецПопытки;
    КонецПроцедуры // ПриОткрытии
    Процедура ПослеОткрытия()									  
    Браузер=СоздатьОбъект("АктивИкс");
    Браузер.УстановитьАтрибут(Форма,"ФБраузер");
    Браузер.СоздатьЭУ("Shell.Explorer.2");
    Браузер.Объект.Navigate("http://www.1cpp.ru");
    КонецПроцедуры
    Процедура ФормаПриСоздании()
    ПослеОткрытия();
    КонецПроцедуры // ФормаПриСоздании
    Процедура ФБраузер_BeforeNavigate2(объект,урл,флаги,фрейм,пост,заголовки,отмена)
    Сообщить(урл);
    отмена=-1;
    КонецПроцедуры // ФБраузер_BeforeNavigate2
    
  4. nickpugachev
    Offline

    nickpugachev Профессионал в 1С Команда форума

    Регистрация:
    28 май 2012
    Сообщения:
    3.266
    Симпатии:
    131
    Баллы:
    104
    я бы сказал, что было это слишком давно :) - завтра погляжу архивы свои на работе

Поделиться этой страницей