7.7 1С 7.7 Бух.учет, ред.4.5 Сортировка товара в печатной форме расходной накладной по Группе

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем Sergio2002, 5 мар 2013.

  1. TopicStarter Overlay
    Sergio2002
    Offline

    Sergio2002 Опытный в 1С

    Регистрация:
    5 мар 2013
    Сообщения:
    58
    Симпатии:
    0
    Баллы:
    26
    Нужно отсортировать товар в печатной форме расходной накладной по Группе (Родитель).
    Колонку Родитель в Табличную часть "ПечатьНакл" я добавил.

    Не могу расписать ТЗ.
    Код:
    [size=4]Процедура ПечатьНакл()  [/size]
    Печать();
    
    ИсхТабл = СоздатьОбъект("Таблица");
    ИсхТабл.ИсходнаяТаблица("Накл");
    
    Пока ПолучитьСтроку() = 1 Цикл			
    Докум= РНК;
    
    
    Если  Докум.МестоХранения.ТипСклада = Перечисление.ТипыСкладов.Услуги Тогда
    продолжить;
    Иначе
    
    [size=4]КонецЕсли;[/size]
    
    
    НачПовт = 0; КонПовт = 0;
    
    
    // секция Заголовок
    НомерДокПечатнойФормы = глПреобразоватьНомерДок(Докум.НомерДок, 0, 0);
    Камера = СокрЛП(Докум.Камера.Наименование)+"	  "+СокрЛП(Докум.Камера.Корпус.Наименование);  
    
    ИсхТабл.ВывестиСекцию("Заголовок");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Заголовок");
    
    // Секция Поставщик
    // формирование адреса поставщика
    Поставщик = СокрЛП(Константа.НазваниеОрганизации);
    Контра = СокрЛП(Докум.Грузополучатель.ПолнНаименование);  
    
    глДобавитьРеквизит(Поставщик, ", ", глПредставлениеАдреса(Константа.АдресОрганизации));
    глДобавитьРеквизит(Поставщик, ", тел. : ", Константа.ТелефоныОрганизации);
    ИсхТабл.ВывестиСекцию("Поставщик");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Поставщик");
    
    // Секция Покупатель
    Покупатель = СокрЛП(Докум.Контрагент.Наименование);  
    
    
    Получатель = СокрЛП(Докум.Получатель);  
    коммент = СокрЛП(Докум.комментарий);  
    статус = СокрЛП(Докум.СтатусНакладной);  
    
    
    глДобавитьРеквизит(Покупатель, ", ", глПредставлениеАдреса(Докум.Контрагент.ЮридическийАдрес));
    глДобавитьРеквизит(Покупатель, ", тел. : ", Докум.Контрагент.Телефоны);
    ИсхТабл.ВывестиСекцию("Покупатель");
    НачПовт = НачПовт + ИсхТабл.ВысотаСекции("Покупатель");
    
    // Секция Склад
    Если ПустоеЗначение(Докум.МестоХранения) = 0 Тогда
    Склад = СокрЛП(Докум.МестоХранения);
    Иначе
    Склад = "";
    КонецЕсли;
    ИсхТабл.ВывестиСекцию("Склад");
    
    // Секция Шапка таблицы
    ИсхТабл.ВывестиСекцию("ШапкаТаблицы");
    КонПовт = НачПовт + ИсхТабл.ВысотаСекции("ШапкаТаблицы");
    
    
    // выводим табличную часть
    НомСтроки = 0;
    Докум.ВыбратьСтроки();
    
    Пока Докум.ПолучитьСтроку() = 1 Цикл
    НомСтроки = НомСтроки + 1;
    ИсхТабл.ВывестиСекцию("Строка");
    КонецЦикла;
    
    СуммаИтог = Докум.Итог("Всего");
    
    // секция Итого
    ИсхТабл.ВывестиСекцию("Итого");
    
    // секция ИтогоНДС
    Если глПризнакУчетаНалога(Докум, "НДС") = 1 Тогда
    СуммаНДСИтог = Докум.Итог("НДС");
    // ИсхТабл.ВывестиСекцию("ИтогоНДС");
    КонецЕсли;
    
    // секция ИтогоНП
    Если глПризнакУчетаНалога(Докум, "НП") = 1 Тогда
    СуммаНПИтог = Докум.Итог("НП");
    // ИсхТабл.ВывестиСекцию("ИтогоНП");
    КонецЕсли;
    
    СуммаИтог = Докум.Итог("Всего");
    Валюта = Докум.Договор.ВалютаДоговора;
    
    // секция СуммаПрописью
    ИсхТабл.ВывестиСекцию("СуммаПрописью");
    
    // секция Подписи
    ИсхТабл.ВывестиСекцию("Подписи");
    ИсхТабл.НоваяСтраница();
    
    КонецЦикла;	
    
    
    ИсхТабл.Опции(0,0,0,0,"ОпцииПечатиНакладной","ОкноНакладной");
    ИсхТабл.ТолькоПросмотр(1);
    ИсхТабл.Показать("Печать накладной","");
    
    КонецПроцедуры
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не можете? Так вы ее нигде и не получаете....
    Выгружайте строки документа в ТЗ. Сортируйте и выводите
Похожие темы
  1. igor_nat
    Ответов:
    1
    Просмотров:
    1.268
  2. Alexandr Beloglazov
    Ответов:
    2
    Просмотров:
    978
  3. Ольга_1C
    Ответов:
    3
    Просмотров:
    793
  4. Sergio2002
    Ответов:
    20
    Просмотров:
    1.300
  5. Fenomen
    Ответов:
    8
    Просмотров:
    799
Загрузка...

Поделиться этой страницей