8.х 1C 8.3 Запись в регистр сведений - контактная информация email контрагента

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем veuron, 18 апр 2014.

  1. TopicStarter Overlay
    veuron
    Offline

    veuron

    Регистрация:
    20 май 2013
    Сообщения:
    16
    Симпатии:
    0
    Баллы:
    1
    Добрый день! После перехода с 1С 7.7 Предприятие -> 1С 8.3 УПП , возникла необходимость добавить в карточки контрагентов email адреса. Адреса хранятся в файле Adresa.DBF. Номер строки в ДБФ файле совпадает с кодом контрагента в 1С 8.3 УПП.
    Если я правильно понял, адреса необходимо закидывать в регистр сведений- контактная информация. Никак не вникну как это реализовать в 1С 8.3 УПП, все что "нарыл" в интернете, но с email ничего нету,подскажите как реализовать, вот код:
    Код:
    Процедура ЗагрузитьНажатие(Элемент)
    Файл = Новый XBase;
    НаборЗаписей = РегистрыСведений.КонтактнаяИнформация.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Объект.Установить("Контрагент");
    НаборЗаписей.Прочитать();
    Файл.ОткрытьФайл("D:\adresa.dbf",,Истина); //открываем для чтения
    Файл.Первая();
    Пока НЕ Файл.ВКонце() Цикл
    Адрес = Файл.ПолучитьЗначениеПоля("Adres");
    Ном = Файл.НомерЗаписи();
    Для каждого Запись из НаборЗаписей Цикл
    Если (Запись.Объект.Код = Ном) и (Запись.Вид = Справочники.ВидыКонтактнойИнформации.НайтиПоНаименованию("Адрес электронной почты контрагента для обмена электронными документ")) Тогда
    Запись.Представление = Адрес;   
    НаборЗаписей.Записать();
    КонецЕсли;  
    КонецЦикла;
    Сообщить(Адрес + " " + Ном);
    Файл.Следующая();
    КонецЦикла;
    Файл.ЗакрытьФайл();
    КонецПроцедуры
    
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.438
    Симпатии:
    373
    Баллы:
    104
    версию конфигурации уточните
    а то они там вроде перекидывали что-то из регистра в справочник
  3. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Регистр сведений "КонтактнаяИнформация", для создания записи потребуется заполнить измерения - "Объект" (ссылка на контрагента) , "Тип" (Перечисления.ТипыКонтактнойИнформации.АдресЭлектроннойПочты), "Вид" (сссылка на запись в справочнике "Справочники.ВидыКонтактнойИнформации" или Строка).
    Далее заполнение ресурсов - "Представление" (весь адрес строкой), "Поле1" .. "Поле10". создайте запись руками, там будет видно что куда ложить.

Поделиться этой страницей