[РЕШЕНО] 1c 8.3 linux не видит програмные лицензии

Тема в разделе "Установка платформы "1С:Предприятие 8"", создана пользователем asch500, 4 фев 2016.

  1. TopicStarter Overlay
    asch500
    Offline

    asch500

    Регистрация:
    4 фев 2016
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Имеется сервер 1с предприятие . и програмные лицензии к нему. сервер поднят как файловый. установлен xrdp . Ubuntu сервер.
    Активация проводилась под админом. соответственно есть 2 файла связанных с лицензиями. первый лежал в
    /home/admin/LicData.txt
    второй :
    /home/admin/.1cv8/1C/1cv8/conf/201**********.lic

    Под админом все работает отлично и напрямую и через терминал, но создав пользователя buh например ругается что не может найти лицензию. в общем то логично, она же в моей локальной папке ( я правда не понимаю почему 1с ее туда засунул). лицензия разумеется многопользовательская.

    вопросы :
    как быть ?
    как прописать 1с откуда брать файл лицензии ?
    почему то под пользователем buh например, ну или любым другим 1с ка запрашивает не .lic файл. а LicData.txt файл, подсунув который полчаем ответ : Aquring a license covering of all users of this computer is not avialable. ( в смысле почему он просит файл запросов а не файл лицензии ? и почему не ест его ?
    --- Объединение сообщений, 4 фев 2016 ---
    Забыл есть еще активная подписка ИТС до мая. можно их напрячь этим ? не понимаю почему платя за софт + за обновления должен с ним :%№ться
  2. TopicStarter Overlay
    asch500
    Offline

    asch500

    Регистрация:
    4 фев 2016
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Разобрались. оказалось нужно вначале дать права всем на /var/1c/licenses
    потом получить лицензию. тогда и только тогда она будет в правильном месте и видеть ее будут все. поскольку она уже была получена ее вырезали и вставили туда. соответственно дав всем юзерам права на эту папку. по заверениям lic@1c.ru важно именно вырезать и вставить файл а не копировать, хотя может это юридический момент, а может и технический...
    Вылезли вторые грабли - при подключении одного пользователя ( любого) все работает нормально. при поытке подключить другого пользователя ( любого ) к той же самой базе вылезает ошибка доступа к базе, при том другая база откроется нормально.
    1с 8.3 линукс клиент, где рыть решение ?
    --- Объединение сообщений, 5 фев 2016 ---
    ошибка вида :
    error opening lock file "/1c_bases/infobase1/1Cv8.1CD
    Последнее редактирование: 5 фев 2016
  3. TopicStarter Overlay
    asch500
    Offline

    asch500

    Регистрация:
    4 фев 2016
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    похоже уже сам нагуглил, дело в правах на файлы которые создаются при входе юзера в базу. ну поскольку никто ничем не помог лень все распиывать. проблема решена

Поделиться этой страницей