8.х УПП 1C 8.2.15.318 КА 1.1.19.1 приходный ордер запрос

Тема в разделе ""1С:Управление производственным предприятием УПП"", создана пользователем bluntschi, 30 июл 2012.

  1. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    Добрый день.

    Нужно на основании приходного ордера проверить, был ли создан документ: поступление товаров и услуг и если был создан, то окрасить в списке приходных ордеров, эти документы в другой цвет. но вопрос в том, как

    есть функция, которая выбирает, документы, для которых созданы поступления товаров и услуг и в ней запрос,


    Код:
    Функция Подчиненный()
    Запрос = Новый Запрос("ВЫБРАТЬ
    |	ПоступлениеТоваровУслугТовары.Ссылка
    |ИЗ
    |	Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
    |ГДЕ
    |	ПоступлениеТоваровУслугТовары.ПриходныйОрдер = &ПриходныйОрдер");
    Запрос.УстановитьПараметр("ПриходныйОрдер",СсылкаНаПриходныйОрдер);
    Возврат Запрос.Выполнить().Выгрузить();
    
    КонецФункции
    


    но когда к ней обращаешься, 1с ругается: переменная не определена (СсылкаНаПриходныйОрдер).

    подскажите, как исправить?
  2. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    но если вместо
    Код:
    СсылкаНаПриходныйОрдер
    , написать просто ПриходныйОрдер, то функция проходит, но уже при обращении, выводит другую ошибку:


    Слишком много фактических параметров (Подчиненный).

    Обращение такое:
    Код:
    Если Подчиненный(ДанныеСтроки.Ссылка)<> Неопределено Тогда
    
  3. Allizar
    Offline

    Allizar Опытный в 1С

    Регистрация:
    24 сен 2006
    Сообщения:
    413
    Симпатии:
    0
    Баллы:
    26
    Так у Вашей функции нет параметров. Что же Вы хотите?
  4. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    я установила Параметр
    Код:
    Функция Подчиненный(ПриходныйОрдер)
    при обращении он теперь ругается:
    Код:
    ДанныеСтроки.Ссылка
    Код:
    Если Подчиненный(ДанныеСтроки.Ссылка)<> Неопределено Тогда	
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    ОформлениеСтроки.ЦветФона = ЦветКрасный;
    
    как обратится к функции тогда?
  5. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Доброго всем,

    Вы текст процедуры (функции) покажите полностью, где используете функцию "Подчиненный()"
  6. Allizar
    Offline

    Allizar Опытный в 1С

    Регистрация:
    24 сен 2006
    Сообщения:
    413
    Симпатии:
    0
    Баллы:
    26
    Как ругается-то?
  7. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    Код:
    Функция Подчиненный(ПриходныйОрдер)
    Результат = Неопределено;
    Запрос = Новый Запрос("ВЫБРАТЬ
    |    ПоступлениеТоваровУслугТовары.Ссылка
    |ИЗ
    |    Документ.ПоступлениеТоваровУслуг.Товары КАК ПоступлениеТоваровУслугТовары
    |ГДЕ
    |    ПоступлениеТоваровУслугТовары.ПриходныйОрдер = &ПриходныйОрдер");
    Запрос.УстановитьПараметр("ПриходныйОрдер", ПриходныйОрдер);
    РезультатЗапроса = Запрос.Выполнить();
    Если НЕ РезультатЗапроса.Пустой() Тогда
    Результат = РезультатЗапроса.Выгрузить()[0].Ссылка;
    //Возврат Запрос.Выполнить().Выгрузить(); 
    КонецЕсли;
    Возврат Результат;
    КонецФункции
    
    и потом тут:
    Код:
    Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок, ДанныеСтроки)
    
    ЦветКрасный = Новый Цвет(255,130,124);
    Если Подчиненный(ДанныеСтроки.Ссылка)<> Неопределено Тогда     
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    ОформлениеСтроки.ЦветФона = ЦветКрасный;
    КонецЦикла;
    
    КонецЕсли;
    
    КонецПроцедуры
    
    Значение не является значением объектного типа (Ссылка)

    Код:
    {Документ.ПриходныйОрдерНаТовары.Форма.ФормаСписка.Форма(120)}: Значение не является значением объектного типа (Ссылка)
    Если Подчиненный(ДанныеСтроки.Ссылка)<> Неопределено Тогда	
    
  8. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    ДанныеСтроки = Неопределно, что в этом случае будет ?
    А у вас функция такое возвращает !
  9. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    да такое, как исправить?
  10. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Я извеняюсь, поторопился... (как всегда)
    нужно поставить точку останова на условие и посмотреть в каком виде приходит "ДанныеСтроки"
    возможно там нет данных с ссылкой
  11. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    если функция не находит документы поступления товаров и услуг, созданных на основании приходных ордерров на товары, из нашего списка ордеров, то она должна окрашивать поля в списке документов с приходными ордерами в голубой цвет
  12. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Я повтарю
    нужно поставить точку останова на
    Если Подчиненный(ДанныеСтроки.Ссылка)<> Неопределено Тогда
    и путем "вычеслить выражение" посмотреть, какие данные в
    ДанныеСтроки
  13. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26

    нет, тогда как к ним обратиться, чтобы выбрать их?


    Если Подчиненный(???)

    он тип данных не указывает, в значении: Ожидается выражение
  14. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Что-то про конфу ничего не увидел. Есть такая фишка как - критерии отбора, вы посмотрите как организована структура подчиненности, отпадут вопросы как найти подчиненный документ.
  15. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26

    Комплексная автоматизация 1.1.19.1
  16. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Смотрите как там реализована структура подчиненности:), приходник же может быть создан не только на основании поступления.
  17. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    мне нужно проверить, создано ли поступление, на основе приходника, и если создано, тогда окрасить
  18. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Попробуйте вместо
    Если Подчиненный(ДанныеСтроки.Ссылка)<> Неопределено Тогда
    написать так
    Если Подчиненный(Элемент.ТекущаяСтрока.Ссылка)<> Неопределено Тогда
  19. TopicStarter Overlay
    bluntschi
    Offline

    bluntschi Опытный в 1С

    Регистрация:
    18 июл 2012
    Сообщения:
    422
    Симпатии:
    0
    Баллы:
    26
    так он ошибку не выдает, но и цветом не выделяет..

    и так тоже не получается Если Подчиненный(ЭлементыФормы.Список.ТекущиеДанные.Ссылка) <> Неопределено
  20. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Воспользуйтесь событием табличного поля "ПриВыводеСтроки"
    Процедура обработчик :
    Код:
    Процедура СписокПриВыводеСтроки(ОформленияСтрок, ДанныеСтроки)
    ЦветКрасный = Новый Цвет(255,130,124);
    Если Подчиненный(ДанныеСтроки.Ссылка)<> Неопределено
    Тогда
    Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл
    ОформлениеСтроки.ЦветФона = ЦветКрасный;
    КонецЦикла;
    КонецЕсли;
    
    КонецПроцедуры
    

Поделиться этой страницей