8.х УТ 11 - Как из документа продажи получить "Счет на оплату клиенту"?

Тема в разделе ""1С:Управление торговлей УТ"", создана пользователем nsk1C, 23 ноя 2017.

  1. TopicStarter Overlay
    nsk1C
    Online

    nsk1C Профессионал в 1С

    Регистрация:
    25 май 2016
    Сообщения:
    1.699
    Симпатии:
    174
    Баллы:
    104
    УТ 11..4.1.254

    Клиент возжелал, чтобы в УПД (ПФ, создаваемой из документа "Заказ клиента" или РТиУ) в поле (подвала) справа от "Основание передачи (сдачи) / получения (приемки)" вместо заказа проставлялся заголовок документа "Счет на оплату клиенту"

    Что-то я не могу сообразить - как из документа РТиУ или из "Заказ клиента" можно вытащить документ "Счет на оплату клиенту", созданный на их основании. В них нет никакой прямой привязки к этому документу

    Или, как вариант, как бы рассказать, что не надо это ему ?
    Последнее редактирование: 23 ноя 2017
  2. kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    582
    Симпатии:
    75
    Баллы:
    54
    Вот мой гавнокод для розница 2.2, заходим в отчет о продажах, далее смотрим у него связанные документы, если есть акт списания то выполняем условия.
    Должно подойти.
    Код:
    Запрос = Новый Запрос;
        Запрос.Текст =
        "ВЫБРАТЬ
        |    ОтчетОРозничныхПродажах.Ссылка КАК СсылкаОтчет
        |ИЗ
        |    Документ.ОтчетОРозничныхПродажах КАК ОтчетОРозничныхПродажах
        |ГДЕ
        |    ОтчетОРозничныхПродажах.Дата МЕЖДУ &ДатаНачалаСозданияАвтоматическихАктов И &ДатаТекущая";
      
        Запрос.УстановитьПараметр("ДатаНачалаСозданияАвтоматическихАктов", ДатаНачалаСозданияАвтоматическихАктов);
        Запрос.УстановитьПараметр("ДатаТекущая", ДатаТекущая);  
        РезультатЗапросаОтчет = Запрос.Выполнить();
        ВыборкаДетальныеЗаписиОтчет = РезультатЗапросаОтчет.Выбрать();
        Пока ВыборкаДетальныеЗаписиОтчет.Следующий() Цикл
          
            Запрос = Новый Запрос;
            Запрос.Текст =
            "ВЫБРАТЬ РАЗРЕШЕННЫЕ
            |    СтруктураПодчиненности.Ссылка
            |ИЗ
            |    КритерийОтбора.СвязанныеДокументы(&ЗначениеКритерияОтбора) КАК СтруктураПодчиненности";
          
            Запрос.УстановитьПараметр("ЗначениеКритерияОтбора", ВыборкаДетальныеЗаписиОтчет.СсылкаОтчет);
            РезультатЗапросаАкт = Запрос.Выполнить();
            ВыборкаДетальныеЗаписиАкт = РезультатЗапросаАкт.Выбрать();
            ЕстьАктыСписания = Ложь;      
            Пока ВыборкаДетальныеЗаписиАкт.Следующий() Цикл
                Если ТипЗнч(ВыборкаДетальныеЗаписиАкт.Ссылка) = Тип("ДокументСсылка.АктСписанияЕГАИС")  Тогда
                    ЕстьАктыСписания = Истина;
                КонецЕсли;
            КонецЦикла;
          
            Если ЕстьАктыСписания = Истина Тогда
                Продолжить;
            Иначе
                СтрОтчеты = Объект.ТЗОтчеты.Добавить();
                СтрОтчеты.НаименованиеОтчета = ВыборкаДетальныеЗаписиОтчет.СсылкаОтчет;
            КонецЕсли;   
          
        КонецЦикла;        
    nsk1C нравится это.
  3. TopicStarter Overlay
    nsk1C
    Online

    nsk1C Профессионал в 1С

    Регистрация:
    25 май 2016
    Сообщения:
    1.699
    Симпатии:
    174
    Баллы:
    104
    Да, я понимаю, что надо перебирать и отбирать, но запрос по ОРП в 1С-Розница для РТиУ в УТ 11.4 - это и близко не то даже на концептуальном уровне - где и как отбирать

    Есть конкретный РТиУ и ЗаказПокупателя (как документ-основание РТиУ) - надо из них
  4. kisol
    Offline

    kisol Профессионал в 1С

    Регистрация:
    25 июл 2012
    Сообщения:
    582
    Симпатии:
    75
    Баллы:
    54
    Так берем документ, получаем запросом что у него есть в КритерийОтбора.СвязанныеДокументы, оттуда берем связанный нужный нам документ и по ссылке получаем его реквизиты.
    -Hungry-
Похожие темы
  1. akelllo
    Ответов:
    3
    Просмотров:
    1.577
  2. materiy_boec
    Ответов:
    1
    Просмотров:
    685
  3. bluntschi
    Ответов:
    7
    Просмотров:
    1.947
  4. ulterior
    Ответов:
    3
    Просмотров:
    2.111
  5. wjack
    Ответов:
    10
    Просмотров:
    1.742
Загрузка...

Поделиться этой страницей