Курилка 1 апреля наступает!

Тема в разделе "Курилка", создана пользователем Stack_G, 20 мар 2010.

  1. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Думал сделать банальную убегающую кнопку с вопросами, да что-то так и не нашел как это реализовать в 1С 8.
    Коллеги, кто что делал, планирует, поделитесь... Уж больно хочется поиздеватся... :)
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Я шутил немного иначе - делал скриншот 1с и помещал на рабочий стол (ярлыки с раб. стола можно спрятать/вернуть за 5 сек). Было прикольно смотреть как жмакали мышкой, матерились и пытались оживить "подвисшую" 1с......
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    При старте выдавать окно с вопросом:

    Сделать все? (Большая зеленая кнопка) и рядом: Поработать самому.

    После нажатия на сделать все: чуток подумать и выдать:
    "Ой, не пошло..."

    И выдать кнопку: переделать все правильно?


    Короче, переиграть стандартную проблему :)
  4. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Супер, но это нужно на всех компах для всех пользователей домена... как-то уж сильно затратно :)
    Я тоже самое хотел с убегающей кнопкой замутить... твоя идея - отличная альтернатива ))))
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Скриптик получается ну уж совсем корокий, но запустить его по сети... Тут вот и ага)))))))))
  6. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26

    Вложения:

  7. iliko
    Offline

    iliko Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    136
    Симпатии:
    0
    Баллы:
    26
    Спасибо за данную обработку
    Мои работники склада смеялись около часа

    У нас есть удаленное подразделение где тетка СОВСЕМ БЕЗ ЧУВСТВА ЮМОРА
    она пыталась минут 5 понять что это такое !!!!

    Оказывается НАЧАЛЬНИК УВИДАЛ у ТЕТКИ на мониторе и закричал: Скорее закрывай! Это вирус!!

    Потом ТЕТКА начала названивать моему сисадмину и разобраться сним что это такое ....

    А он тоже СОВСЕМ БЕЗ ЧУВСТВА ЮМОРА ....

    я в одном кабинете - и когда услышал про сапог - подсказал что это шутка ....

    ТЕТКА и мой СИСАДМИН сошлись во мнении что 1С - КОЗЛЫ
    когда сказал что это моя шутка -- второй час со мной не разговаривает

    ------------------------------------------------
    а реакция складских работников была приблизительно такая

    ------------------------------------------------
    :unsure: ой не могууууууууууууууу
    ------------------------------------------------
    Витка рыдает уже :smile:
    ------------------------------------------------
    ну всё
    мы под столом
    вам не слышно как мы ржем??? :aua:
    ------------------------------------------------
  8. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Всегда пожалуйста )) я, к сожалению, сегодня отстуствовал по личным причинам, не смог насладиться ((
    А таких товарищей я настроечкой отрубил от обработки... от греха подальше )))
  9. iliko
    Offline

    iliko Опытный в 1С

    Регистрация:
    6 май 2008
    Сообщения:
    136
    Симпатии:
    0
    Баллы:
    26
    А вот и проверилось кто же у нас без чувства юмора ,
    я предположить не мог что у меня системщик , не понимает юмора
  10. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Смотри! Еще так пошутишь, придется не только помощника искать :unsure:
  11. Vlad
    Offline

    Vlad Модераторы Команда форума Модератор

    Регистрация:
    16 авг 2006
    Сообщения:
    3.517
    Симпатии:
    19
    Баллы:
    29
    Есть такая старая присказка: "Первоапрельская шутка обернулась Новогодним подарком!". :unsure:
  12. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    А что это, простите, за издание 1С-овой направленности?
  13. TopicStarter Overlay
    Stack_G
    Offline

    Stack_G Опытный в 1С

    Регистрация:
    10 дек 2007
    Сообщения:
    786
    Симпатии:
    2
    Баллы:
    26
    Журнал Сестемный администратор, из названия понятно, что он не 1С-овской направленности, но иногда проскакивает :)
  14. bard
    Offline

    bard

    Регистрация:
    4 июн 2010
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Я бы процедуры в обработке исправил на нечто такое:
    Код:
    Процедура ЭлементУправления1MouseMove(Элемент, Button, Shift, X, Y)
    
    ГСЧ = Новый ГенераторСлучайныхЧисел();
    СЧ = ГСЧ.СлучайноеЧисло(ЭлементыФормы.КоманднаяПанель1.Высота, ЭтаФорма.Высота);
    Если СЧ >= ЭтаФорма.Высота Тогда
    
    СЧ = СЧ + 10;
    ЭлементыФормы.ЭлементУправления1.Верх = СЧ;
    СЧ = СЧ + 5;
    ЭлементыФормы.ЭлементУправления1.Лево = СЧ;
    
    Иначе
    
    СЧ = СЧ - 10;
    ЭлементыФормы.ЭлементУправления1.Верх = СЧ;
    СЧ = СЧ - 5;
    ЭлементыФормы.ЭлементУправления1.Лево = СЧ;
    
    КонецЕсли; 
    
    КонецПроцедуры
    
    
    Процедура ЭлементУправления2MouseMove(Элемент, Button, Shift, X, Y)
    
    ГСЧ = Новый ГенераторСлучайныхЧисел();
    СЧ = ГСЧ.СлучайноеЧисло(ЭлементыФормы.КоманднаяПанель1.Высота, ЭтаФорма.Высота);
    Если СЧ >= ЭтаФорма.Высота Тогда
    
    СЧ = СЧ + 10;
    ЭлементыФормы.ЭлементУправления2.Верх = СЧ;
    СЧ = СЧ + 5;
    ЭлементыФормы.ЭлементУправления2.Лево = СЧ;
    
    Иначе
    
    СЧ = СЧ - 10;
    ЭлементыФормы.ЭлементУправления2.Верх = СЧ;
    СЧ = СЧ - 5;
    ЭлементыФормы.ЭлементУправления2.Лево = СЧ;
    
    КонецЕсли; 
    
    КонецПроцедуры
    
    Цихварки прибавления и вычитания из СЧ можно сделать под себя...)))
  15. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Попробуйте вывести на экран юзерам что-то подобное и понаблюдайте за реакцией....
    Меня в пятницу позабавило))))))))))

    Вложения:

  16. mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    Спасибо, рассмешил :unsure:

    Это знакомый клиенту базу обновил, только забыл что для тестирования сумму документа проверял, если вводишь сумму 10^12 то програмка отвечает "Вы ввели о...........уенно огоромное число", самое интересное клиент позвонил на следующий день :smile:
  17. dedalx7
    Offline

    dedalx7 Опытный в 1С

    Регистрация:
    20 май 2009
    Сообщения:
    97
    Симпатии:
    0
    Баллы:
    26
    :/

    Леплю такие предупреждения везде где только можно. И все равно умудряются напартачить. ))
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Потому что не читают

Поделиться этой страницей